LibreOffice

Page last edited 586 giorni 22 ore fa
Da wiki.betaingegneria.it.
Errore nella creazione della miniatura: Impossibile salvare la miniatura nella destinazione

Libreoffice: YAOT (yet another office tool)?[modifica]

Nel 2011 Oracle ha acquisito Sun per cui ha preso dentro tutto lo sviluppo di Java, by side, anche OpenOffice.org.

Il gruppo degli sviluppatori open source ha allora aperto un nuovo progetto LibreOffice che parte da OpenOffice e rimane Open Source.

Ma a giugno Oracle ha donato il progetto all'Apache Software Foundation. Ora OpenOffice era distribuito con licenza GPL2 e non può essere rilasciato con Licenza Apache poiché la GLP2 non è permissiva verso la AL2 (anche se è possibile il contrario).

Ci sarebbe il workaround di fare un rilascio in GPL3, per cui la FSF ammetterebbe poi il passaggio ad AL2, se non che questo passaggio è invece interdetto dalla ASF...

Sostituire Open Office con Libre Office in Ubuntu[modifica]

per rimuovere OpenOffice dal sistema;[modifica]

  sudo apt-get autoremove openoffice.org-*

per inserire LibreOffice nei repository;[modifica]

  sudo add-apt-repository ppa:libreoffice/ppa

per aggiornare i repository[modifica]

  sudo apt-get update

per scaricare e installare LibreOffice;[modifica]

  sudo apt-get install libreoffice

per scaricare il pacchetto necessario a integrare l’interfaccia di LibreOffice con Gnome;[modifica]

  sudo apt-get install libreoffice-gnome

per abilitare l’importazione dei PDF in LibreOffice;[modifica]

  sudo apt-get install libreoffice-pdfimport

per dotare LibreOffice dell’interfaccia in italiano;[modifica]

  sudo apt-get install libreoffice-l10n-it

per dotare LibreOffice del correttore ortografico italiano.[modifica]

  sudo apt-get install language-support-it

in avvio si blocca per il ripristino[modifica]

Di solito, se il file esiste ancora, è una utility utile che ripara il file che non è stato chiuso correttamente. Ma se il file non esiste più (ad esempio era stata aperta una copia dalla cache dopo un download) diventa fastidioso perché è un'operazione destinata a fallire sempre.

Soluzione: cancellare il registro delle modifiche:

  $ rm ~/.config/libreoffice/3/user/registrymodifications.xcu

Fonte

In caso di ripensamenti, per ripristinare OpenOffice e cancellare LibreOffice basta far riferimento all'Ubuntu Software Center.

HOWTO: piccoli trucchi o semplici istruzioni per fare cosa[modifica]

Eliminare un collegamento ipertestuale[modifica]

Posizionarsi sopra l'ipertesto, cliccare tasto destro e selezionare Elimina collegamento

Eliminare apici prima dei numeri[modifica]

Questo è un espediente di LibreOffice per far apparire una stringa come numero o data ma trattandolo come stringa:

Errore nella creazione della miniatura: Impossibile salvare la miniatura nella destinazione

È una prassi che LibreOffice segue, ad esempio, quando si importa un file CSV o si popola un foglio ODS con copia/incolla

Come si può osservare nella figura, si vede 20/02/2016 allineato a sinistra nella cella, ma nell'area di editing si scopre che in realtà c'è scritto '29/02/2016.

Se si clicca tasto destro sulla cella e si visualizza la formattazione si vedrà che non è una data ma testo.

Per eliminare gli apici iniziali dalle date occorre usare le espressioni regolari per il trova/sostituisci; quindi scegliere

 Modifica > Trova e sostituisci
  • nella casella Trova inserire l'espressione regolare ^. (cappuccio punto)
  • nella casella Sostituisci inserire l'espressione regolare &
  • sotto, nelle maggiori opzioni, assicurarsi che sia selezionata la casella Espressioni regolari.
  • lanciare l'operazione e il gioco è fatto.

[Fonte http://www.ryananddebi.com/2009/11/29/remove-apostrophes-before-numbers-in-openoffice-calc/]

Macro con LibreOffice[modifica]

Si possono riunire utilmente operazioni ripetitive che prevedono più di un click in apposite subroutine chiamate macro. Le macro possono essere salvate nel documento oppure nella libreria di macro di LibreOffice così da risultare condivisibili da qualsiasi documento.

LibreOffice organizza così le macro:

  • macro
  • moduli (modules)
  • librerie (libraries)
  • contenitori (containers)

ogni oggetto di ogni riga contiene uno o più oggetti della riga sopra

Per scrivere una macro occorre aprire l'editor Basic, una IDE integrata in LibreOffice:

 Strumenti > Macro > Organizza macro > LibreOffice Basic...

come indicato in figura

Errore nella creazione della miniatura: Impossibile salvare la miniatura nella destinazione

Un intero container (e non solo una singola macro o una singola libreria) può essere contenuto in un singolo documento, come anche essere visibile invece a livello di applicazione da tutti i documenti.

Cliccando su LibreOffice Basic si apre il dialog qui sotto:

Errore nella creazione della miniatura: Impossibile salvare la miniatura nella destinazione

Come si può osservare, ci sono due sezioni:

  • le macro personali
  • le macro di LibreOffice (di sistema)

Per ogni item ho l'elenco delle libraries e per ciascuna library l'elenco dei moduli (nell'esempio nelle librerie a livello di applicazione ho la libreria Euro che contiene i moduli AutoPilotRun, Common, ConvertRun, etc. Ad esempio selezionando ConvertRun nella colonna a destra -- Macro presenti in ConvertRun -- si vede l'elenco delle singole subroutine: Main, SelectListItem, etc).

Come ultima azione, possiamo aprire la singola macro nella IDE e vederne il contenuto. Nella figura che segue abbiam aperto, premendo il pulsante Modifica, la Macro ConvertRun, che contiene, per esempio, la funzione SelectListItem.

Errore nella creazione della miniatura: Impossibile salvare la miniatura nella destinazione

Creare nuovi moduli e librerie[modifica]

La finestra di gestione dei moduli è un po' diversa da quella di Open Office: non esiste il pulsante "Nuovo", al suo posto c'è il pulsante "Elimina". Come si fa a creare un nuovo modulo? Si preme su Gestisci e poi su Nuovo. Alcuni suggerimenti e fatti sostanziali:

  • Si possono importare librerie da un container ad un altro
  • Non si può importare un singolo modulo, bisogna importare tutta la libreria che lo contiene
  • La libreria Standard viene caricata da LibreOffice ogni volta che si apre un documento; non può quindi essere importata
  • Il tool di sviluppo consente di creare nuovi moduli e nuove librerie

Per creare un nuovo modulo dalla finestra di dialogo Macro Libreoffice Basic, cliccare su gestisce poi su Nuovo, come in figura:

Errore nella creazione della miniatura: Impossibile salvare la miniatura nella destinazione

Notare bene che la finestra di gestione (Gestione Macro Basic) ha tre linguette o tab:

  • Moduli (per creare nuovi moduli)
  • Dialoghi (per creare nuove finestre di dialogo)
  • Librerie (per importare librerie).

Assegnare una macro ad una sequenza di tasti[modifica]

Per far partire una macro si può sempre passare per l'editor, ma non possiamo chiedere questo all'omino della strada, per cui attiveremo la nostra macro con una sequanza di tasti, ad esempio una sequenza libera è Shift + Maius + S, come assegnare il tasto all'evento?

dal menu Strumenti > Personalizza si apre la maschera di dialogo rappresentata qui sotto:

Errore nella creazione della miniatura: Impossibile salvare la miniatura nella destinazione

Selezionare dapprima la linguetta Tastiera e poi occorre compilare la maschera scegliendo l sequenza di tasti, possibilmente libera, dal riquadro in alto. Poi si seleziona la funzione da associare al tasto, sfogliando prima la categoria e poi la funzione, nel riquadro Funzioni sotto.

Color Code Colorizer[modifica]

Se si vuole velocemente formattare brani di codice scritto in (quasi) qualsiasi linguaggio di programmazione.

Scaricare Sito

Dal Libreoffice

   Menu > Strumenti > Gestione estensioni > Aggiungi (selezionare i file OXT appena scaricato)

Poi per usarlo, selezionare il testo, e

   Menu > Strumenti > Add-on > MacroFormatterADP > (Linguaggio che si vuole) > Colorize Selected