Apt

Page last edited 1 924 giorni 22 ore fa
Da wiki.betaingegneria.it.

Apt è una libreria per gestire i package in Debian. Di riflesso è anche la libreria per gestire packages per Ubuntu.

E' l'acronimo di Advanced Packaging Tool.

Qui c'è un bel [tutorial (sito Debian)].

Nello svolgere le sue operazioni, APT usa un file che contiene la lista delle "sorgenti" dalle quali può attingere i pacchetti. Questo file è /etc/apt/sources.list.

Il mio file ad esempio è così (solo un estratto)

 root@jsbach:~# cat /etc/apt/sources.list
 ...
 ## Uncomment the following two lines to add software from Ubuntu's
 ## 'extras' repository.
 ## This software is not part of Ubuntu, but is offered by third-party
 ## developers who want to ship their latest software.
 # deb http://extras.ubuntu.com/ubuntu precise main
 # deb-src http://extras.ubuntu.com/ubuntu precise main
 
 #BOINC - VirtualBox
 deb http://download.virtualbox.org/virtualbox/debian precise contrib
 
 #SPOTIFY
 deb http://repository.spotify.com stable non-free

Le ultime due righe le ho aggiunte per installarmi BOINC (software di calcolo distribuito per il CERN) e un programma di musica. La prima parola di ogni riga, deb o deb-src, indica il tipo di archivio: se contiene pacchetti binari (deb), che sono i pacchetti già compilati che normalmente usiamo, o se l'archivio contiene i pacchetti sorgente (deb-src), che sono il codice originale del programma con l'aggiunta del file di controllo (.dsc) e del file diff.gz che contiene i cambiamenti necessari per "debianizzare" il programma.

Come faccio a capire se un pacchetto X è già installato nel mio OS?[modifica]

Come faccio a sapere se un pacchetto (ad esempio ia32-libs) è già installato? Mi porto ad essere root:

  $ sudo -s
  # apt-cache show ia32-libs
  Package: ia32-libs
  Priority: optional
  Section: universe/libs
  Installed-Size: 40
  Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
  Original-Maintainer: Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>
  Architecture: amd64
  Version: 20090808ubuntu36
  Provides: ia32-libs-gtk, ia32-libs-sdl, lib32v4l-0
  Depends: ia32-libs-multiarch
  Breaks: flashplugin-installer (<< 10.3.183.4ubuntu4), nspluginwrapper (<< 1.4.4-0ubuntu2)
  Filename: pool/universe/i/ia32-libs/ia32-libs_20090808ubuntu36_amd64.deb
  Size: 4570
  MD5sum: 4b295afcc97b484d1594159f7dda6337
  SHA1: a98cab1c03c9547b9c31178318ebc888900f99d5
  SHA256: b9b606f08b4003993d7cd80b25f5ad4b1e1549e4d894258c35a78e4dc1d615b4
  Description-en: ia32 shared libraries - transitional package
   This is a transitional package depending on ia32-libs-multiarch, an i386-only
   metapackage that depends on all of the libraries that were previously
   included in this package.  If no other packages are installed that depend
   on this package, it can be safely removed.
  Description-md5: abea08296eb03bbfec6601033318c72a
  Bugs: https://bugs.launchpad.net/ubuntu/+filebug
  Origin: Ubuntu
  
  Package: ia32-libs
  Priority: optional
  Section: universe/libs
  Installed-Size: 40
  Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
  Original-Maintainer: Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>
  Architecture: amd64
  Version: 20090808ubuntu35
  Provides: ia32-libs-gtk, ia32-libs-sdl, lib32v4l-0
  Depends: ia32-libs-multiarch
  Breaks: flashplugin-installer (<< 10.3.183.4ubuntu4), nspluginwrapper (<< 1.4.4-0ubuntu2)
  Filename: pool/universe/i/ia32-libs/ia32-libs_20090808ubuntu35_amd64.deb
  Size: 3362
  MD5sum: d6a9b3017c6aca27c39488ed28398c88
  SHA1: f40d0c86f82b13ec6f88a0555abb3def19fd66c8
  SHA256: 803e8c085876f8c406ea26e1f716b3e30998da37d47568ad6354a208cb0a8295
  Description-en: ia32 shared libraries - transitional package
   This is a transitional package depending on ia32-libs-multiarch, an i386-only
   metapackage that depends on all of the libraries that were previously
   included in this package.  If no other packages are installed that depend
   on this package, it can be safely removed.
  Description-md5: abea08296eb03bbfec6601033318c72a
  Bugs: https://bugs.launchpad.net/ubuntu/+filebug
  Origin: Ubuntu
  

Il comando mi visualizza due blocchi, in questo caso identici. Il primo è la versione disponibile per l'installazione e il secondo è quello già installato. Quindi il pacchetto ia32-libs ce l'ho già installato.

come si fa?[modifica]

apt-source[modifica]

apt-get per installare nuovi pacchetti[modifica]